ODBC 2.2.8 automake failing on EL5

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ODBC 2.2.8 automake failing on EL5

Kevin Moody

Hi All,

 

First off, please let me know if obscure build questions are meant for the support mailing list.  I’ll gladly post there.  I just wasn’t sure.

 

Second, our ODBC 2.2.8 build, which was working fine on our old RHEL 4 build machines, fails to configure properly on both our 32-bit and 64-bit CentOS 5.8 machines. 

 

Here is what we are seeing:

 

make[6]: Nothing to be done for `install-data-am'.

make[6]: Leaving directory `/builds/jenkins/workspace/build/objydb/develop/8ebc22e0/src/sql/unixODBC/src/DRVConfig/drvcfg1'

make[5]: Leaving directory `/builds/jenkins/workspace/build/objydb/develop/8ebc22e0/src/sql/unixODBC/src/DRVConfig/drvcfg1'

Making install in drvcfg2

make[5]: Entering directory `/builds/jenkins/workspace/build/objydb/develop/8ebc22e0/src/sql/unixODBC/src/DRVConfig/drvcfg2'

cd ../.. && \

/bin/sh /builds/jenkins/workspace/build/objydb/develop/8ebc22e0/src/sql/unixODBC/linux86_64/src/missing --run automake-1.7 --gnu DRVConfig/drvcfg2/Makefile

configure.in:3: error: m4_defn: undefined macro: _m4_divert_diversion

aclocal.m4:6425: AM_INIT_AUTOMAKE is expanded from...

configure.in:3: the top level

autom4te: /usr/bin/m4 failed with exit status: 1

configure.in: no proper invocation of AM_INIT_AUTOMAKE was found.

configure.in: You should verify that configure.in invokes AM_INIT_AUTOMAKE,

configure.in: that aclocal.m4 is present in the top-level directory,

configure.in: and that aclocal.m4 was recently regenerated (using aclocal).

 

My internet search yielded this: http://www.delorie.com/gnu/docs/autoconf/autoconf_163.html

 

But, my autoconf/automake knowledge is weak, at best.  I was hoping to figure out if there is a patch to configure.in that I could apply.

 

autoconf (GNU Autoconf) 2.59

automake (GNU automake) 1.9.6

 

Regards,

Kevin

 


_______________________________________________
unixODBC-dev mailing list
[hidden email]
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-dev
Reply | Threaded
Open this post in threaded view
|

Re: ODBC 2.2.8 automake failing on EL5

Nick Gorham-2
On 03/04/15 23:37, Kevin Moody wrote:

Hi All,

 

First off, please let me know if obscure build questions are meant for the support mailing list.  I’ll gladly post there.  I just wasn’t sure.

 

Second, our ODBC 2.2.8 build, which was working fine on our old RHEL 4 build machines, fails to configure properly on both our 32-bit and 64-bit CentOS 5.8 machines. 

 

Here is what we are seeing:


HI,

Not sure, but 2.2.8 is over 10 years old, so is probably out of step with the gnu build tools, my suggestion would be to use the current release, if only because of 10 years of bug fixes.

Failing that, you could try rebuilding configure using your current tools,

There should be a Makefile.svn, but if not

        libtoolize --copy --ltdl --force
        aclocal -I m4
        automake --add-missing
        automake
        autoheader
        autoconf

Then configure again as before.

--
Nick

_______________________________________________
unixODBC-dev mailing list
[hidden email]
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-dev