AIX isql failure

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

AIX isql failure

David Ritter-3
Hello,
 
I have built unixODBC 2.3.2 for AIX 6.1 (with Visual Age 11.1) and I am having trouble running isql. I am seeing this error:
 
[ritter@bluff] > isql QE197UTF user pass
NON-FATAL ASSERTION FAILED!!!
Time       = Thu Jan  9 14:23:00 2014
Expr       = Invalid block eye-catcher (0x0) found at:
PID        = 9633852
TID        = 1
File       = GlobalReg.C
Line       = 4074
Stacktrace =
             _ossMemAllocCheck (+0x688)
             _ossMemFree (+0x54)
             __dl__9GlobalRegFPv (+0x2C)
             __dt__9GlobalRegFv (+0x74)
             EnvGprfRefresh__FP11SEnvProfile (+0x354)
             EnvPrfOpen__FPCciPP11SEnvProfile (+0x1BC)
             EnvRegGetProfile__FP12SEnvRegistryPCciPP11SEnvProfile (+0x22C)
             sqloPRegQueryDefaultValue__FiPcPCc (+0x7C)
             EnvGetDB2SysVar__FiPcUl (+0x12C)
             EnvQueryDB2SystemVariables__Fv (+0x294)
             sqloInitEnvironment__Fv (+0x160)
             sqloAppLibInit (+0x44)
             mod_init1 (+0xA4)
             __loadinit (+0x194)
             load1 (+0x19C)
             load (+0x90)
NON-FATAL ASSERTION FAILED!!!
Time       = Thu Jan  9 14:23:00 2014
Expr       = Invalid pad type (0x0) found at:
PID        = 9633852
TID        = 1
File       = GlobalReg.C
Line       = 4074
Stacktrace =
             _ossMemAllocCheck (+0x630)
             _ossMemFree (+0x54)
             __dl__9GlobalRegFPv (+0x2C)
             __dt__9GlobalRegFv (+0x74)
             EnvGprfRefresh__FP11SEnvProfile (+0x354)
             EnvPrfOpen__FPCciPP11SEnvProfile (+0x1BC)
             EnvRegGetProfile__FP12SEnvRegistryPCciPP11SEnvProfile (+0x22C)
             sqloPRegQueryDefaultValue__FiPcPCc (+0x7C)
             EnvGetDB2SysVar__FiPcUl (+0x12C)
             EnvQueryDB2SystemVariables__Fv (+0x294)
             sqloInitEnvironment__Fv (+0x160)
             sqloAppLibInit (+0x44)
             mod_init1 (+0xA4)
             __loadinit (+0x194)
             load1 (+0x19C)
             load (+0x90)
[ISQL]ERROR: Could not SQLConnect
 
Has anyone else seen this/reported it?
 
I am using DB2. I am using an odbc.ini and odbcinst.ini from my unixODBC 2.3.0 installation, which is working correctly, so I feel pretty sure that the DSN is set up correctly and is valid.
 
Any help/advice would be appreciated.
 
Thanks!
David
 

_______________________________________________
unixODBC-support mailing list
[hidden email]
http://mailman.unixodbc.org/mailman/listinfo/unixodbc-support